Comandos Nivel 500

Nivel 500

Manager de canal

PART - Hace que X salga del canal. Para hacer que X permanezca fuera del canal, refiérase al comando AUTOJOIN (Nivel 500).

/msg x part <#canal>

SET - Fija las flags para su canal. Flags son las opciones especiales que le dicen a X como comportarse en ciertas condiciones.

/msg x set <#canal> <autojoin|massdeoppro|noop|strictop> <valor>

Flags y Valores:

AUTOJOIN - Cuando la opción está ON, hace que X siempre entre a su canal. (ejemplo: después de mantenimiento o Netsplit). Cuando está OFF, lo hará salir si está en el canal, y no regresará después de un Netsplit.

/msg x set <#canal> autojoin <on|off>

MASSDEOPPRO - Número máximo de deops que X permite a un usuario (vea la nota) en un periodo de 15 segundos. Cualquier usuario que sobrepase el límite será suspendido (si tiene access) por 5 minutos y tendrá un ban nivel 25 para impedir que tenga op y necesitará enviar el comando unban después que expire la suspensión.

NOTA: La versión actual de MASSDEOPPRO comprueba solamente cuando los usuarios realizan deops con el comando de /mode, no con el comando de DEOP con X.

/msg x set <#canal> massdeoppro <0-7>

NOOP - - Esto significa que nadie puede ser un operador del canal excepto X. Esto no significa que usted no pueda ejecutar comandos con la X en el canal. Si usted se autentifica, usted puede ejecutar comandos como el KICK, BAN, a través de X, solo que usted no puede subir a op.

/msg x set <#canal> noop <on|off>

STRICTOP - Este comando permite a usuarios de nivel 100+ que están autentificados subir a op.

/msg x set <#canal> strictop <on|off>


Comandos Nivel 450

Niveles 450 - 499

Administrador Confiado del Canal

JOIN - Hace que X entre a su canal. Para hacer que la X entre siempre automáticamente a su canal refiérase al comando SET AUTOJOIN (Nivel 500)

/msg x join <#canal>

SET - Fija las flags para su canal. Flags son las opciones especiales que le dicen a X como comportarse en ciertas condiciones.

/msg x set <#canal> <flag> <valor>

Flags y valores:

AUTOTOPIC - Esta opción hace que X restablezca el tópico del canal cada 30 minutos con el texto fijado en la URL y DESCRIPTION. Note que si el canal está inactivo, el tópico no se restablecerá en ese tiempo.

/msg x set <#canal> autotopic <on|off>

DESCRIPTION - Establece el tópico del canal predeterminado (máximo 80 caracteres). Este tópico se utiliza sólo cuando AUTOTOPIC está ON. El comando puede verse con el comando CHANINFO (Nivel 0), o logeándose en CService Web Interface. Si ningún texto en la descripción se especifica, la descripción actual se remueve.
Alias: DESC

/msg x set <#canal> description [texto]
/msg x set <#canal> desc [texto]

FLOATLIM - Activa o desactiva la opción del Floating-limit. Si está activada, X restablecerá el límite del canal con un número predeterminado por encima del número actual de usuarios en el canal, y con un número predeterminado de tiempo. Esta opción evita las entradas masivas al canal, evitando inundaciones a éste. Esta opción se encuentra desactivada, si se activara en el comando STATUS se mostrarán los modos en la línea de "flags set".

Por ejemplo:

"Flags set: FLOATLIM (MGN:3, PRD:20, GRC:1, MAX:0)"

En este ejemplo, FLOATLIM esta ON, con un FLOATMARGIN de 3, un un FLOATPERIOD de 20 segundos, un FLOATGRACE de 1, y un FLOATMAX en OFF.

Refiérase a los comandos SET FLOATGRACE, SET FLOATMARGIN, SET FLOATMAX y SET FLOATPERIOD para más información

/msg x set <#canal> floatlim <on|off>

FLOATGRACE - Fija el floating-limit grace del canal. Si la diferencia entre el límite actual y lo que el límite nuevo sera, es menos que el valor grace, X no restaurará el límite, para que de esta manera los canales callados no se floodeen con los cambios de límite. Los valores pueden ser entre 0 y 19. El valor por defecto es 1.

/msg x set <#canal> floatgrace <0-19>

FLOATMARGIN - Fija el valor del floating-limit margin para ser usado en el canal. Este número puede ser entre 2-20. El límite que X restablecerá será: el número de usuario en el canal + el fijado en el FLOATMARGIN. El valor predeterminado es 3.

/msg x set <#canal> floatmargin <2-20>

FLOATMAX - Fija el límite máximo para el floating-limit. Este puede ser cualquier número deseado, y prevendrá que X cambie el límite a un número más alto que el número que usted determine. De este modo, es posible para un canal limitar cuantos usuarios quieren en el canal en un tiempo deseado. El valor por defecto es 0 (off).

/msg x set <#canal> floatmax <0-65536>

FLOATPERIOD - Fija el periodo del floating-limit en segundos, para ser usado antes de que X restablezca el límite del canal. Este número debe ser entre 20 y 200. El valor predeterminado es de 20 segundos.

/msg x set <#canal> floatperiod <20-200>

KEYWORDS - Establece palabras claves para el canal. X usa estas palabras claves cuando un usuario envía el comando SEARCH (Nivel 0). Si no se especifica nada al enviar el comando, los valores actuales serán removidos. La extensión máxima de largo de palabras claves son 80 caracteres.

/msg x set <#canal> keywords [texto]

MODE - Este comando guardará los modos actuales del canal. Cuando X entre a un canal, restablecerá aquellos modos si es que no están puestos en ese momento.

/msg x set <#canal> mode

URL - Usted puede anunciar la dirección de la página web de su canal con esta opción (máximo de 75 carácteres). Se permiten espacios, permitiendo especificar los parámetros de URL multiples. Esto no afecta el tópico del canal, a menos que AUTOTOPIC esté en ON (Nivel 450). La DESCRIPTION y URL pueden ser vista usando el comando CHANINFO (Nivel 0), o logueándose en CService Web Interface luego clic en "Channel Information" e ingresa el nombre del canal. Si la URL no se especifica, la URL actual se remueve.

/msg x set <#canal> url [url(s)]

USERFLAGS - Fija por defecto el AUTOMODE cuando un nuevo usuario se agrega a la lista de usuarios (userlist). El valor predeterminado es 0 (Ninguno).

NOTA: Una vez el usuario está en la lista de usuarios, el comando MODINFO AUTOMODE (Nivel 400) puede enviarse para cambiar el valor exclusivamente para ese individuo.

Valores:

0 = No AutoMode puesto para todos los usuarios agregados.
1 = Op AutoMode para todos los usuarios agregados.
2 = Voice AutoMode para todos los usuarios agregados.

/msg x set <#canal> userflags <0-2>


Comandos Nivel 400

Niveles 400 - 449

Administrador de Lista de Usuarios

ADDUSER - Agrega a un usuario a la lista de usuarios (userlist) del canal. Usted no puede AGREGAR a alguien con acceso igual o más alto que el suyo.

/msg x adduser <#canal> <username> <access>

CLEARMODE - Este comando limpia todos los modos del canal. Puede ser usado cuando su canal ha sido cerrado (puesto en +i, +l o en +k sin su consentimiento).

NOTA: Este comando necesariamente no es el mejor método para ganar la entrada a su canal, porque otros usuarios o bots pueden tener fijados el modo de operador en el canal y pueden restablecer los modos cuando usted los limpia. Refiérase al comando de STATUS (Nivel 200) para información relacionada.

/msg x clearmode <#canal>

MODINFO - Los comandos siguientes pueden usarse para hacer cambios a los usuarios existentes en la lista de usuarios (userlist) de su canal.

/msg x modinfo <#canal> <access|automode> <username> <valor>

valores:

ACCESS - Cambia el nivel de acceso de un usuario. El nivel de acceso puede fijarse entre 1 y uno menos de su propio nivel (si usted tiene un nivel de acceso de 400, el máximo nivel que usted puede asignar es un nivel de 399 a otros usuarios.

/msg x modinfo <#canal> access <username> <nuevo nivel>

AUTOMODE - Cambia el automode de un usuario a uno de los modos especificados: NONE, OP, o VOICE. De acuerdo a esta fijación, X dará Op o Voice cuando un usuario autentificado entre al canal, o si el usuario está ya en el canal, el automode ocurrirá una vez que el usuario se autentifique con X. None hara que la X no haga nada cuando entre el usuario autentificado en el canal.

/msg x modinfo <#canal> automode <username> <none|op|voice>

REMUSER - Remueve a un usuario de la base de datos del canal. Usted debe tener acceso más alto que el usuario que usted quiere remover. Usted también puede removerse de cualquier canal, con tal de que usted no sea el Gerente del Canal (nivel 500 de acceso en ese canal).

/msg x remuser <#canal> <username>


Comandos Nivel 200

Nivel 200

Lista de Usuarios

KICK - Hace a X patear a todos los usuarios que coincidan con el *!*userid@host mask especificado, pero no patea a la persona que envía el comando si ellos también coinciden. Su uso debe limitarse extremadamente a un canal que ha sido floodeado o a clones. Usted puede querer poner un ban en la máscara, o activar el modo +i (modo de invite only) en el canal antes de enviar el pateo para prevenir que los usuarios pateados regresen al canal. Su username aparecerá en el mensaje del kick cerrado entre paréntesis.

/msg x kick <#canal> <nick| *!*userid@host> [razón]

STATUS - Muestra todas las opciones especiales, modos del canal, el número de usuarios y ops en el canal, usuarios actualmente autentificados en el canal y si X está en el canal o no. Se muestran los usuarios actualmente autentificados en un formato: "username/nickname (nivel)". El nickname de los usuarios sólo se mostrarán si el usuario está actualmente en el canal, por otra parte se despliegan sólo su username y nivel.

La habilidad de ver los modos del canal es sumamente útil en caso de que el canal esté cerrado (modos de canales +i, +l o +k). Si el canal esta con invite-only (+i) o tiene un límite lleno de usuarios (+l) usted puede usar el comando INVITE para entrar al canal. Si el canal tiene puesto una llave (+k) X le mostrará la llave actual que tiene el canal. Usted también puede usar el comando CLEARMODE para remover todos los modos y poder entrar al canal.

/msg x status <#canal>


Comandos Nivel 100

Niveles 100 - 399

Operador del Canal

DEOP - Le quita el op a uno o más usuarios en su canal. Si ningún nick se especifica, y usted es op en el canal, X le quita el op a usted.

/msg x deop <#canal> [nick] [nick2] ... [nickN]

OP - Le da Op a uno o más usuarios en su canal. Si ningún nick se especifica, y usted no es op en el canal, X le da op a usted.

/msg x op <#canal> [nick] [nick2] ... [nickN]

INVITE - Hace que X lo invite a su canal. Permitiéndole que usted logre entrar sin importar los modos actuales del canal.

/msg x invite <#canal>

SUSPEND - Suspende el acceso de un usuario de la lista de usuarios con X de su canal por el periodo especificado de tiempo al nivel especificado. Si el nivel no se especifica, el nivel predefinido de la suspensión que se usará será el nivel de acceso del emisor. Usted solamente puede suspender a alguien con acceso más bajo que el suyo. La máxima duración es 372 días (8928 horas, 535680 minutos).

Los Valores de Tiempo:

  • D = días
  • H = horas
  • M = minutos

/msg x suspend <#canal> <username> <duración> [nivel]

UNSUSPEND - Des-suspende el acceso de un usuario a X en la lista de usuarios de su canal. Usted solamente puede des-suspender a alguien con acceso más bajo que el suyo, con tal de que el nivel de la suspensión también es menos o igual a su propio nivel de acceso.

/msg x unsuspend <#canal> <username>


Comandos Nivel 75

Niveles 75 - 99

Nuevo Operador del Canal

BAN - Agrega un *!*userid@host específico a la lista de ban de X de su canal. Si el usuario esta online, usted puede poner el ban al nick, y X automáticamente baneará el *!*userid@host de ese usuario.

Eso cubre un ancho más grande, reemplazando los bans que anteriormente se habían definido. Cualquier usuario en el canal que coincida a un ban determinado será pateado del canal si el nivel de este ban es de 75+. La duración es en horas, con un máximo de 336 horas (2 semanas). El nivel del ban puede ser de 1 a su propio nivel. La razón del ban puede ser de un máximo de 128 caracteres de largo. Si ninguna duración se especifica, el valor predeterminado será de 3 horas y el nivel de 75. Su username aparecerá en el mensaje del ban cerrado entre paréntesis.

NOTA: Si el usuario baneado tiene el “hostmask virtual" de Undernet (el modo +x del usuario) fijado, X puede considerar con el ban a su actual host, así que baneando su username vía *!*@*username. * también prohibirá su host actual.

Niveles de Ban:

1-74 le impide al usuario tener ops (+o) en el canal.
75+ le impide al usuario entrar en absoluto en el canal.

/msg x ban <#canal> <nick|*!*userid@host> [duración] [nivel] [razón]

UNBAN - Remueve los ban de la lista de bans con X de su canal y cualquiera que también coincida con los bans de la lista de bans del canal. Usted puede remover sólo bans de la lista de bans con X si el nivel del ban es igual a más bajo a su propio acceso. Para investigar la lista de bans con la X (como está puesto el ban), refiérase al comando LBANLIST (Nivel 0). Para ver la lista actual de ban refierase al comando BANLIST (Nivel 1).

/msg x unban <#canal> <nick|*!*userid@host>


Comandos nivel 50

Niveles 50 - 74

Confiado Regular del Canal

>KICK - Hace a X dar kick a alguien de su canal; la razón es opcional. Su username aparecerá en el mensaje del kick cerrado entre paréntesis.

/msg x kick <#canal> <nick> [razón]

TOPIC - Hace a X cambiar el tópico en su canal (máximo de 145 carácteres) e incluye su username, puesto entre paréntesis, al principio del tópico.

NOTA: Si una DESCRIPTION o URL ha sido fijado y AUTOTOPIC está ON, el tópico del canal se borrará en 30 minutos, a menos que el canal este inactivo.

/msg x topic <#canal> <tópico>


Comandos Nivel 25

Niveles 25 - 49

Canal Regular

DEVOICE - Quita voz a uno o más usuarios en su canal.

/msg x devoice <#canal> [nick] [nick2] ... [nickN]

VOICE - Pone voz a uno o mas usuarios en su canal.

/msg x voice <#canal> [nick] [nick2] ... [nickN]


Comandos Nivel 1

Nivel 1

Acceso Minimo

BANLIST - Muestra la lista de bans del canal. Este comando trabaja si usted está en el canal o está fuera de el.

/msg x banlist <#canal>

REMUSER - A este nivel, y al anterior REMUSER nivel 400, usted puede removerse de cualquier canal, con tal de que usted no sea el Gerente del Canal (500 de nivel de acceso en ese canal).
Los Gerentes de Canales que deseen removerse deben purgar su canal o transferirlo a otro usuario.

/msg x remuser <#canal> <tu username>

STATUS - Este comando despliega todos los flags fijados, el número de usuarios y operadores en el canal, los actuales usuarios autentificados en el canal y si la X esta en el canal o no. Se muestran los usuarios actualmente autentificados en un formato: "username/nickname (nivel)". El nickname de los usuarios sólo se mostrarán si el usuario está actualmente en el canal, por otra parte se despliegan sólo su username y nivel. Este comando hace la misma función que el comando STATUS nivel 200, excepto no informará los modos del canal (+nt etc.) a ningún usuario con acceso debajo de 200.

/msg x status <#canal>


Comandos Nivel 0

Nivel 0

Todos los demas

ACCESS - Puede ver el acceso de cierta persona por medio de su nick o username o multiples usuarios por medio de los patrones de los comodines. La información indica: el nivel de access, el automode fijado, el estado de la suspensión y si suspendió, y cuando el usuario fue visto por última vez.

El * sólo le mostrará 15 entradas de access desde el 500 hacia abajo. Si quieres ver la lista completa de access entra en CService Web Interface loguease y haga clic en "Channel information", escriba el nombre del canal y busca en la lista de acceso.

Usted también puede usar y puede combinar estas opciones para conseguir resultados específicos.

/msg x access <#canal> <*|patrón|username|=nickname>[-min<Nivel>][-max<Nivel>][-modif] [-none|-voice|-op]

Opciones:

* - Le muestra la lista completa de access del canal.

/msg x access <#canal> *

patrón - Le nuestra el nivel de acceso de todos los username que coincidan con el patrón del comodin.

/msg x access <#canal> <patrón>

username - Muestra el nivel de acceso de un solo usuario.

/msg x access <#canal> <username>

=nickname - Muestra el nivel de access de un usuario por medio de su nickname.

/msg x access <#canal> <=nickname>

-min <nivel> - Muestra solamente los usuarios sobre el nivel dado.

/msg x access <#canal> -min <nivel>

-max <nivel> - Muestra solamente los usuarios debajo del nivel dado.

/msg x access <#canal> -max <nivel>

-op - Muestra solamente los usuarios con el OP fijado en AUTOMODE.

/msg x access <#canal> -op

-voice - Muestra solamente usuarios con la VOZ fijada en AUTOMODE.

/msg x access <#canal> -voice

-none - Muestra solamente los usuarios que no tienen fijados AUTOMODE (None).

/msg x access <#canal> -none

-modif - Muestra quién fue el último en modificar la lista de acceso.

/msg x access <#canal> -modif

CHANINFO - Le muestra información de si un canal es o no registrado, quien es el dueño, y la DESCRIPTION y URL, si está actualmente fijada
Alias: INFO

/msg x chaninfo <#canal>

/msg x info <#canal>

HELP - Le muestra información de ayuda sobre un comando especificado.

/msg x help [comando]

INFO - Le muestra información sobre un username, tal y como su nick y userid@host están visibles además su lenguaje y configuración invisible. Su última información vista y si fueron suspendidos por un administrador de CService.

Si envía el comando para usted, le muestra su dirección del correo electrónico registrado, los últimos hostmask (el formato nick!userid@host) usado, cuando el username fue logueado, su fijación de maxlogins, y le enumera todos los canales que usted tiene acceso (solamente CService y usted podrán ver su información, otro usuario no podrá verla). Si usted desea que ésta información sea escondida al público, refiérase al comando SET INVISIBLE (Nivel 0).

/msg x INFO <username>

ISREG - Verifica si un canal esta registrado o no.

/msg x isreg <#canal>

LBANLIST - Investiga la lista de ban con la X para cierta cadena usuarios. Use * para ver la lista entera, o especifique un patrón de comodin para encontrar un ban específico.

Si hay más de 15 entradas entra en CService Web Interface loguease y haga clic en "Channel information", escriba el nombre del canal y busque en la lista de ban.

/msg x lbanlist <#canal> <patrón>

LOGIN - Esto carga su inscripción de acceso en la memoria de X y lo autentifica en todos los canales que usted tiene acceso.

/msg x@channels.undernet.org login <username> <contraseña>

MOTD - Despliega el mensaje del día de la X.

/msg x motd

SEARCH - Hace a X listar canales donde los parámetros dados en la búsqueda coincidan con las palabras claves (keywords) fijadas en el canal, sea cualquiera. El uso de wildcards (asteriscos *) no se requiere. Un máximo de 10 resultado le serán mostrados.

/msg x search <palabra clave>

SET - Cambios de modos especiales para su username.

/msg x set <invisible|lang> <valor>

INVISIBLE - Esta es una fijación personal que le permite cambiar la visibilidad de la información de su username, recuperable con el comando de INFO para ser visible o oculto. Para aprender más sobre la información disponible, refiérase al comando INFO (Nivel 0).

/msg x set invisible <on|off>

NOADDUSER - Esta es otra fijación personal. Cuando la opción está ON, hace que X no permita que su username sea agregado a otro canal sin su autorización.

/msg x set NOADDUSER on/off

LANG - Cambios del idioma para X contestarle a usted.

/msg x set lang <codigo del lenguaje>

Lenguajes Disponibles:

             Código   -   el Idioma
               ar    -    Arabic
               ca    -    Catalán
               ch    -    Christmas
               de    -    Alemán
               dk    -    Dinamarqués
               ea    -    Easter
               en    -    Inglés
               es    -    Español
               fr    -    Francés
               gr    -    Griego
               ha    -    Halloween
               hu    -    Húngaro
               it    -    Italiano
               mk    -    Macedonian
               nl    -    Holandés
               no    -    Noruego
               pt    -    Portugués
               ro    -    Romano
               sv    -    Svenska
               tr    -    Turco

SHOWCOMMANDS - Muestra todos los comandos que usted puede usar en un canal, según su nivel de acceso. Si ningún canal se especifica, entonces sólo los comandos nivel 0 se muestran.

/msg x showcommands [#canal]

SHOWIGNORE - Muestra la lista de ignorados por X. Si alguien intencionalmente o accidentalmente floodea a X, automáticamente X fijará 1 hora en la cual ignorará al usuario que envia el flood.

NOTA: X no le contestará si usted ha sido ignorado. Si usted no recibe respuestas de X, pregunte a un amigo para que verifique en la lista de ignore si usted ha sido ignorado por la X

/msg x showignore

SUPPORT - Un método alternado que le permite confirmar o negar el apoyo por un canal si en la aplicación usted se lista como un apoyador. Al autentificarse, X le notificará de cualquier aplicación del canal que usted se lista como un apoyador y también lo notificará de este comando de SUPPORT.

Alternativamente, usted puede escoger ver la aplicación en la página de CService y observar más información sobre el, poner una objeción, y confirme o niegue su apoyo de allí. El comando no será eficáz si usted no aparece listado en un canal como un apoyador, o un canal no tenga una aplicación pendiente en la página de CService.

/msg x support <#canal> <yes|no>

VERIFY - Muestra si una persona está logueada o no, y en ese caso, muestra su username, y también indica si es o no es Administrador de CService Oficial o Representante, y/o Operador de IRC. .

/msg x verify <nick>


Notas de Sintaxis

Sintaxis de comandos

  • Los comandos son mostrados en un texto en MAYÚSCULA AZUL NEGRITA.
  • Las variables de los comandos y las opciones se muestran en un texto Rojo Negrita.
  • Los ejemplos de los comandos se muestran como Fuente con un fondo gris claro
  • Los parámetros adjuntados en <>'s son obligatorios.
  • Los parámetros adjuntados en []'s son opcionales.
  • el x|y significa x o y.
  • <nick> se refiere al apodo de una persona en el IRC.
  • <username> se refiere a la cuenta username de una persona como aparece en la lista de usuarios registrada en CService; para no ser confundido con el <username>. Para más información sobre el username y cómo determinar el username de una persona, refiérase a los comandos INFO y VERIFY (Level 0).
  • Todos los comandos mostrados con el campo del pueden también trabajarse especificando el nickname del usuario en el IRC si ellos están online, poniendo al frente de su nickname un signo de igual (=).

Por ejemplo, considere a una persona con el nickname ^Prueba^ y el username Prueba2k3. El comando de ACCESS puede realizarse en este usuario en cualquiera de estos 2 métodos.

  1. /msg x access <#canal> Prueba2k3
  2. /msg x access <#canal> ^Prueba^

El método 1 pregunta diréctamente a X si el username "Prueba2k3" está o no en la lista de usuarios. El método 2 hace que X busque el username de ^Prueba^ si está autenticado, le mostrará el nivel de access de la cuenta del username Prueba2k3. Esto puede realizarse con cualquier comando que requiere un <username>, pero sólo trabajará si el usuario está autentificado, por otra parte X contestará con un "No hay coincidencias!" o su equivalente.

* <patrón> a cualquier búsqueda de cadenas utilizando comodines (* y ?).
Las cadenas de *!*userid@host es un ejemplo de patrones de comodines.

Por ejemplo, los dos comandos, tanto el ACCESS como el LBANLIST siguen <el patrón>:

../msg x access <#canal> ?irc*
../msg x access <#canal> *.users.undernet.org

El comando ACCESS mostrará cualquier username en el canal que coincida con la cadena del comodín ?irc*.
El comando de LBANLIST mostrara todos los bans de los usuarios con el host virtual de undernet (modo +x).

Nota para los Modos Especiales de Canales:

Undernet ha puesto dos nuevos modos en ejecución (un modo del canal, y un modo del usuario) que se relacionan directamente con el sistema de la cuenta del username de CService.

  • +r es un modo del canal que restringe el canal a permitir "usuarios registrados solamente", significando esto que solo los usuarios que tengan registrados su cuenta de username con CService y que estén logueados con X puede entrar a ese canal.

  • +x es un modo del usuario que permite un "Hostmask virtual de Undernet", que enmascarará o esconderá su dirección verdadera de host/IP con el users.undernet.org. Otros usuarios verán este hostmask virtual en vez de su dirección real de host/IP. Sin embargo, los CService Admin y los IRC Ops pueden ver atraves del modo +x, al igual que con X,. Por supuesto, usted podrá siempre ver su host/IP verdadero. A diferencia del hostmask virtual que otros servidores del IRC usan, el de Undernet no puede quitarse, el usuario debe desconectarse de Undernet para desabilitarlo.

    Nota para los scripters:

    Los scripts de IRC deben siempre usar/msg x@channels.undernet.org para todos los comandos para evitar que se rompa el script en el evento de un cambio temporal de nick para la X u otra circunstancia.


Cambios

Lista de la Historia de los Comandos

NO somos responsables: Las revisiones y las actualizaciones a la lista de comandos de X.s detallada adjunto son solamente las que afectarían directamente a usuarios en forma o la función. Esta sección no está basada en los arreglos Generales de Bug's y las actualizaciones al código de X.s. Cualquier persona interesada en tal información puede encontrarla en http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/gnuworld/gnuworld/mod.cservice/ pues es fuente abierta a todos. Algunas de las fechas del inicio del 2001 no pueden ser exactas en cuanto a el día real que ocurrió el cambio porque solamente se daba una lista de actualizaciones que tuvieron lugar desde la última actualización oficial de xcmds.txt. De la última parte de 2001 al presente, todas las fechas deben ser la fecha real que ocurrió la actualización.
9 de Abril del 2003

  • Se agregó el Código Macedonian del "mk" al comando del SET LANG.

30 de Diciembre del 2002

  • El SET MAXLOGINS fue removido en Undernet debido al abuso. Junto con él, el comando del SUSPENDME también removido, debido a que los dos trabajaban juntos. MAXLOGINS se ha fijado a 1 para todos los usuarios, y no es configurable.

6 de Noviembre del 2002

  • Se agregó el Código Svenska del " sv " al comando del SET LANG.

31 de Octubre del 2002

  • Se agregó el Código Alemán del " de " y Griego del " gr " al comando del SET LANG.

30 de Agosto del 2002

  • Se agregó el Código Easter “ ea ” y Halloween (holiday) del " ha " al comando del SET LANG

22 de Abril del 2002

  • Se agregó el Código Hebreo al comando del SET LANG

20 de Abril del 2002

  • agregó el Código Portugués “ pt ” al comando del SET LANG

10 de Marzo del 2002

  • El comando de NEWPASS fue quitado para ayudar a prevenir algún abuso si un usuario escribía accidentalmente su contraseña de CService en público. De ahora en adelante, el interfaz de la página de CService será la única manera de cambiar la contraseña.

4 de Marzo del 2002

  • La forma para el comando del INFO ha sido revisada para mostrar el nuevo ajuste de MAXLOGINS y a todos los usuarios autorizados actualmente.

  • La forma para el comando del STATUS del nivel 200 ha estado revisada para mostrar todos los nicks registrados en el username actual.

24 de de Febrero del 2002

  • Se agregaron medidas de anti-hijacking al username, permitiendo a más de un usuario la conexión a un username pero los usuarios serán notificados, junto con fijar un límite de cuántos usuarios pueden estar logueados, y la capacidad de suspender la cuenta y de hacerla investigar. Esto se ha puesto en ejecución con nuevos comandos del nivel 0: SET MAXLOGINS y SUSPENDME.

  • El comando de LOGIN fue modificado al funcionar dentro de el los ajustes del nuevo comando del SET MAXLOGINS y de SUSPENDME.

5 de Enero del 2002

  • Dos comandos más flotantes del límite del usuario fueron agregados: SET FLOATGRACE y SET FLOATMAX

  • La ejecución del comando del STATUS ha sido revisada para acomodar todos los nuevos ajustes de FLOATLIM en una línea y la vieja referencia de FloodPro finalmente se ha quitado.

  • Se le hizo un arreglo de menor importancia al comando SUSPEND: la X daba un mensaje de error si se utilizaban mayúsculas para especificar la duración; el comando no hace diferencia ahora.

27 de Diciembre del 2001

  • Fue agregado un límite flotante de usuarios del canal. Los comandos siguientes del nivel 450 fueron agregados: SET FLOATLIM, SET FLOATMARGIN, y el SET FLOATPERIOD.

21 de Diciembre del 2001

  • El comando INFO, cuando está utilizado por el mismo usuario, ahora muestra su hostmask pasado y la dirección de e-mail actual con CService.

  • Se agregó el Código arábico del "ar" al comando del SET LANG

25 de Agosto del 2001

  • El SET FLOODPRO fue removido. Los nuevos cambios a IRC han hecho este ajuste obsoleto y no funcional. El comando del STATUS todavía exhibe el "FloodPro: Ajuste de N ", sin embargo, será removido mas adelante.

  • La descripción actualizada del comando del STATUS: los nicks del usuario no saldrán a menos que ese usuario esté en el canal. Esto es actualmente molestoso en la X, pero es como se planea trabajar y solo necesita de un poco de trabajo de parte de los codificadores

12 de Agosto del 2001

  • Se agrego el comando SUPPORT

9 de Agosto del 2001

  • El comando BANLIST es ahora del nivel 1 y muestra la lista de bans sin importar si el usuario está o no en el canal, haciendo el comando más útil.

  • Se agregó un parámetro [Nivel] opcional al comando del SUSPEND, que funciona exactamente de la misma manera que [Nivel] en los comandos de BAN y de UNBAN.

20 de Julio del 2001

  • Se incluyó la duración máxima del SUSPEND, y también cambió la sintaxis de [duración] puesto que es un parámetro requerido del comando del SUSPEND.

  • Se agregó una nota sobre el STATUS que trabaja de cualquier forma si X está en el canal o no.

  • El SET MODE solamente trabaja si X está en el canal.

  • Fue renombrado MASS KICK (nivel 200) para simplemente Kickear ya que que es el comando real.

19 de Julio del 2001

  • El SET LANG fue quitado de los comandos del nivel 500, y se movió al nivel 0 y modificado para fijar el idioma preferido de los usuarios individuales.

  • Fue agregada la descripción del comando INFO

  • Fue agregado el tiempo por defecto (predefinido) del BAN a la descripción del BAN

  • Cambió la descripción de la sintaxis del SET AUTOJOIN para ser consistente con el formato del < on|off >.

4 de Marzo del 2001

  • La nueva y mejorada X hace su primera aparición en Undernet! X ahora es el único BOT del Servicio de Canales para Undernet; y la W se va para bien.

3 de Marzo del 2001

  • Ace termina el primer xcmds.txt para la nueva X y todos aguardamos ansiosamente la llegada de la X a Undernet.


Creditos

Servicios para Canales de Undernet

Lista de comandos x

El documento original xcmds.txt de Cservice fue actualizado por Ace.
La versión xcmds-es.txt. fue traducida al español por veroushka y el documento
xcmds-es.chm fue creado el 8 de enero de 2006.

Este archivo es mantenido por el Comite de Cservice de Undernet.
Para cualquier sugerencia o comentario cservice@undernet.org.

Servicio para Canales de Undernet.
Canal oficial: #cservice.